1

Recently I installed the CS50 appliance for VirtualBox, and found that it will not connect through my ethernet cable on eth0.
I searched for other answers, and changed the port in /usr/bin/ip50 from eth1 to eth0 and installed the guest dkms (as per this question), where my cable is connected on my computer. (Apparently /usr/bin/ip50 and /bin/ip50 were empty files when I used nano), However, update50 says it cannot download the updater, and ping google.com doesn’t work either. Can somebody help?

Here are my system's specs:

  • Ubuntu 13.10 (Saucy Salamander)
  • Internet connection is ethernet cable through eth0 port
  • VirtualBox 4.3.24 r98716

    And for the appliance:

  • Using CS50 Appliance 19 (could not find 2014 edition)

  • Operating System: 32-bit Fedora
  • Base Memory: 512 MB
  • Adapter 1: Not Attached
  • Adapter 2: Host-Only Adapter (vboxnet0)
  • Adapter 3: Bridged Adapter (eth0)

If anyone knows anything about this problem, please share your information, because I can't complete the course without this. Thank you in advance.

  • What are the network configurations of the appliance under its settings in VBox? – Kareem Apr 9 '15 at 19:01
  • @Kareem What it says in the description, under Adapters 1, 2, and 3. – ASCIIThenANSI Apr 9 '15 at 19:03
  • yes, a screenshot of each adapter would be great! – Kareem Apr 9 '15 at 19:04
  • @Kareem I don't see why that's necessary, it's all in the text. Is there something I could be missing, because I can put it in the question. – ASCIIThenANSI Apr 9 '15 at 19:06
  • 1
    You'll have a hard time completing the course using appliance 19 as well (which is a separate issue but ... ) manual.cs50.net/appliance/2014/#how_to_install_appliance – curiouskiwi Apr 10 '15 at 6:07
1
+100

Try setting your Adapter 1 as NAT and disabling the other 2 adapters. You may need to enable the Host-only adapter later (when you reach pset7).


Update: you should also enable the "Cable-connected" option as per the screenshot below

enter image description here

| improve this answer | |
  • This dosen't work. All I get is 'no IP address'. Maybe I have to re-enable or rewrite something? – ASCIIThenANSI Apr 9 '15 at 22:18
  • @ASCIIThenANSI some people have no IP address but they have the internet working. What's your situation? – Kareem Apr 9 '15 at 23:10
  • I see no IP address and no connection. I even tried re-enabling the other adapters, but no luck. – ASCIIThenANSI Apr 10 '15 at 13:27
  • @ASCIIThenANSI just to confirm, does your first adapter settings match this? – Kareem Apr 11 '15 at 13:44
  • Well, well, it appears to have worked. Could you modify your answer to specifically state that the 'Cable Connected' option needs to be enabled for ethernet? – ASCIIThenANSI Apr 11 '15 at 14:41
0

It looks like more of an issue of VMware being unable to access your network adapter than with the appliance within. If you have appliance 19 installed, you may also have a downlevel of VMware Workstation, since they were probably installed from the same source. The problems are piling up.

As painful as it may be, I suggest completely uninstalling both the appliance and VMware workstation, as they appear to both be downlevel, whether actual software version or how they're configured, and install the current versions for the 2015 class. (You may also have license issues because of this with downlevel software.) As curiouskiwi said, the instructions are at

https://manual.cs50.net/appliance/2014/#how_to_install_appliance

You should also print out those instructions and read through and understand them before you start. Then, check off each step on the printed copy to make sure you don't miss anything. It only takes one little mistake to break things.

If this doesn't fix the problem, focus on troubleshooting the network adapter. My bet would be on that first one that is not attached. There are a number of articles on troubleshooting networks and network adapters in the VMware knowledge base. Unfortunately, without being hands-on, it's going to be very painful to troubleshoot via this forum. Also, make sure that you don't have any network issues outside of VMware. (I assume it's good, because you've posted this question, unless you used a different computer.)

| improve this answer | |
  • I may be wrong but i think the question is about Virtualbox and not VMware. – wallek876 Apr 10 '15 at 11:30
  • @wallek876 Yes, the question is about Virtualbox. And my computer's network is fine, it's Virtualbox's. – ASCIIThenANSI Apr 10 '15 at 13:22
  • Oops, my bad. It was late. However, whether it is Virtualbox or VMware, the logic is the same. Even if Virtualbox is the current version, I'd still remove and reinstall it. In fact, if you can, test internet access before installing the appliance. And like VMware, there are user forums for Virtualbox that may be of help too. – Cliff B Apr 10 '15 at 18:59
0

If you have enough capacity on your computer, it may be helpful to install an additional guest machine. That way, you will be able to isolate the problems related to the appliance from those caused by the hardware or the hypervisor (i.e., VMware or VirtualBox). Use the default settings for each and then compare the settings for the appliance with those for the other guest.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .