0

I am trying to run the staff's version of caesar to see how it works and keep getting this return. What does this mean and how can I get this to work for me? I have run update50 and my version is 2014-29. Thanks!

0

You have a typo, easy mistake to make. It isn't cd50, it's cs50. change the 'd' to an 's'.

If this fixes your problem, please mark this question as answered. Let's keep up on forum housekeeping. ;-)

| improve this answer | |
  • Thanks, that was silly. But now with that change I get an output of Usage: /home/cs50/pset2/caesar <key> – HMiddleton May 4 '15 at 3:31
  • That's the program telling you that it wasn't invoked correctly. It expects you to also give the encryption key as a parameter. The good news is that you indeed did run it! – Cliff B May 4 '15 at 3:44
  • I'm not sure what this means, I have tried to add a 13, a 26 , ROT13 after the ~cs50/pset2/caesar and was rick rolled but don't know what I should be doing as far as the <key> – HMiddleton May 4 '15 at 4:12
  • The <key> is any integer greater than or equal to zero. For example, if you wanted to invoke with a key of 12, the command is ~cs50/pset2/caesar 12 This will start the program. Next, it will sit there, waiting for you to type in a string to be encoded. When you hit enter, it will generate the encoded version of the input string and return you to the command prompt. – Cliff B May 4 '15 at 4:35
  • Thank you, it looks like I had used 26 as the key which was returning what I entered (as it should) even though this was confusing me. Additionally, I tried ROT13 and not 13 which returned nothing which kept me confused. Thanks to your answer, I now have it working. – HMiddleton May 4 '15 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .