I've been trying to do pset6 and wanted to access the server on the virtual machine through my host (using Chrome browser outside the appliance). I plugin in the ip address and port number (making sure that I plugged them in correctly every time) into the browser (outside appliance) and access the server (inside appliance) but all I get on my host's Chrome side is ERR_CONNECTION_TIMED_OUT and no print out from the terminal running the server in the appliance. FYI, the chrome browser inside the appliance works just fine and can access the file.

I've tried several things to get it working that really didn't work and tried doing the 'Access Appliance from another Computer' section of the cs50 manual but all that gave me when I tried it was 'eth2 is already configured.' and no inet address was set to 'eth2.' I'll try researching more on my own to try and find a workaround but I don't want to poke around too much on the appliance and potentially break the thing.


1 Answer 1


I am not exactly sure...I believe, by being a virtual web server, it doesn't have an internet domain. i.e it only lives within cs50's web server so its inaccessible outside your application which you run through your command line? I've never evem heard of the Access Appliance from another Computer before!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .