Questions tagged [flask]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
1answer
402 views

IndexError in initial state of pset6 Sentiments

I am working on Pset 6, Sentiments and followed the steps to create my app on twitter. I added keys, installed requirements.txt and did everything in order, but when I type "flask run" and visit the ...
2
votes
2answers
616 views

Using jinja to render template based on previous url - pset7 finance

For the finance website homepage, I want to render index.html differently based on the previous url. For example, if I logged in I want to render a panel saying 'logged in', but if I registered I want ...
1
vote
1answer
5k views

Pset7, Index: How to use loops in Python and Jinja?

I felt like I could understand the for loops great in c, but seem to be hitting a wall here. Some generic conceptual questions before i get into it: 1) ANSWERED. what sequence does the program run, ...
0
votes
1answer
41 views

jinja code not working inside html file

I am using flask for the first time and jinja code is being displayed on the webpage. this is my html file: <!DOCTYPE html> <html lang="en"> <head> ...
5
votes
1answer
35k views

How to get a value using flask, from a selected option in a drop down list?

I have the following code for my form in HTML: <div class="container-fluid" id="feedback"> <p><h2>Give us your feedback on the cafe!</h2> <h4><em>...
0
votes
1answer
1k views

Help needed for CS50 IDE flask server

Please help as I have landed into a trouble with my flask server for pset8/mashup. Per the spec within mashup/ I execute pip install --user -r requirements.txt and then in a terminal window I execute ...
5
votes
1answer
4k views

cs50 finance / pset-7 confused on index() table

I am trying to work on pset7, but am having a problem printing it out to the screen in the table format. I have all the values I need (the values I have are correct), but just can't figure out how to ...
1
vote
1answer
473 views

Pset 7 - Finance: Clicking Register creates: AttributeError: 'ValueError'

I've been trying to get my register page to work for a couple days now. I think I'm close , but now I'm receiving the following error message in my terminal when I try to click register from the login ...