Questions tagged [linux]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
192 views

Unable To Install CS50 Library for C on Android Termux

I downloaded cs50 library for C per the instructions on cs50 docs site. I then unzip it and run sudo make install but it display the error below: No superuser binary detected. Are you rooted? I'm ...
0
votes
1answer
31 views

Pong assignment, using linux Mint

I am very new to the whole world of coding so I apologize for the novice questions. I have tried starting the Pong assignment and I cannot for the life of me figure out how to open the Pong that I ...
0
votes
1answer
416 views

Compilation error in hello.c: undefined reference to `get_string'

I'm getting the following error after running make hello. I downloaded the latest version of libcs50from the GitHub releases page and installed using sudo make install. I'm running the program on ...
0
votes
1answer
19 views

l produces same result as ls when typed into terminal?

I was typing ls into my terminal and accidentally hit enter after typing just l. To my surprise this prints out the same list of files and directories as typing ls would have produced: ~/workspace/...
1
vote
1answer
90 views

API_KEY and API_SECRET are shown using set | grep API_KEY, but error nonetheless

I have set my API_KEY and API_SECRET. I can actually see them using set | grep API_KEY. The correct KEY is shown API_KEY in red and then the exact same value of the API_KEY. I checked, no spaces ...
1
vote
2answers
350 views

running phpliteadmin on local machine?

I'm trying to work on pset7 on my linux machine (I don't have the best internet connection and this results in cloud9 being slow and occasionally buggy). I've gotten almost everything installed and ...
0
votes
1answer
74 views

Double Tab Command Line - Partial Word - List

On my Linux command line, when I type a letter, or a group of letters (such as 'fr','nan', or 'ca'), pressing the tab key twice lists the following (using the above examples): fr: free freetype-...
1
vote
1answer
69 views

Problems with style50 using emacs

Sorry guys, but I'm not used to use gedit, so I use emacs instead The problem with emacs is that I don't know how to set properly the .emacs file in order to indent lines properly. Can anyone help ...
0
votes
0answers
166 views

Linux Appliance for the CS50 Course

Since I am already running Linux Unbuntu will I still need to download the Linux Appliance for this course ? The reason why I am asking is I have limited hard drive space due to the fact I have a ...
0
votes
1answer
291 views

Cannot connect to internet in Bare Metal

I just installed the CS50 Appliance in Bare Metal so that the O.S. could use all of my Laptop's RAM. But I can't connect to the internet, can you guys help me? I don't know anything in Linux.
0
votes
1answer
94 views

appliance50 only shows on a blank screen in VMware

I'm running a a mid 2010 MacbookPro with OSX 10.9.4 and have installed VMware and downloaded appliance50. When I try to run it however, I don't see a desktop, just a black screen with a cursor that ...
0
votes
3answers
271 views

sudo gedit /etc/hosts ERROR

As per the instruction for PSET7 I need to do execute the following in the terminal window. sudo gedit /etc/hosts In order to make changes in "read-only" file Executing the above give me this error ...
6
votes
6answers
8k views

How to Install the Tools for the Course on Ubuntu

As per the question I have had nothing but trouble trying to use the virtual versions of the cs50 software, namely the virtual machine crashes runs slowly or just generally feels like my fingernails ...
2
votes
2answers
729 views

Appliance install on Linux - No go with VMware or VirtualBox on Linux Mint, Ubuntu

Do any of my fellow students have the appliance up and running on a Linux box? If you do please let me know what Linux distribution you are running, which installation instructions you followed that ...