Skip to main content

Questions tagged [nonetype]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
2 answers
110 views

TypeError: 'NoneType' object is not subscriptable in PSET9, but working manually

I am working on pset9 Finance. I have implemented the functionality for purchasing stocks, and it works well when I manually test it. However, when I run the CS50's check50 validation, it returns an ...
Chris's user avatar
  • 31
0 votes
1 answer
29 views

PSET 9 Finance - NONETYPE error after querying db

Need help solving this error: File "/workspaces/finance/app.py", line 223, in sell if available_shares < shares: TypeError: '<' not supported between instances of 'NoneType' and 'int' ...
David Ng's user avatar
0 votes
1 answer
819 views

pset8 finance - 'NoneType' object is not subscriptable - issue

I have read in other comments that API may return error sometimes due to volume and others. Is there a way around it? Can we temporary bypass the issue, or is there any way to continue checking other ...
meh362's user avatar
  • 5
1 vote
1 answer
6k views

TypeError: a bytes-like object is required, not 'NoneType' in Finance

I finished doing finance and tested it without many errors i would say. Fun fact, i was implementing a change password and it got me this error TypeError: a bytes-like object is required, not '...
Inju69's user avatar
  • 11
0 votes
2 answers
711 views

pset7: check50 error - sell page has all required elements

I'm having an argument with check50 on pset7 finance, when it comes to the SELL part. The web app works fine and I'm able to sell my stocks. When I run check50, though, it keeps telling me that the ...
Andrea Tassera's user avatar
1 vote
1 answer
87 views

NoneType Non-subscriptable ... but only sometimes

I'm not sure if I understand this correctly. I've written the following bit of simple code: for portfolio in portfolios: symbol = portfolio["symbol"] look = lookup(symbol) price = float(...
Mike Betto's user avatar
1 vote
1 answer
2k views

Issue with Check50 PSET7 buy.html :( buy handles valid purchase

:( buy handles valid purchase application raised an exception (see log for details) Log sending POST request to /login sending POST request to /buy exception raised in application: TypeError: '...
AvocadoFire's user avatar
1 vote
1 answer
203 views

Pset 7 - Cannot replicate None type not subscritable error

I am running check50 on my code and at buy, it cannot validate a purchase because Log sending POST request to /login sending POST request to /buy exception raised in application: TypeError: '...
Zachary Ellison's user avatar
1 vote
2 answers
8k views

Final Project - request.form.get() returns a None type

I'm currently working on my final project. I know that the number of people who will be able to answer this question is small, but it won't hurt to ask. So here it is: for some reason, user_email = ...
Jason_V's user avatar
  • 182
0 votes
1 answer
512 views

pset7 finance- quote 'nonetype' object error

I am new to python and am very confused by this error message: AttributeError: 'NoneType' object has no attribute 'startswith' I think it has something todo with nothing being passed into the lookup ...
Iris Frenzy's user avatar