Questions tagged [ubuntu]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
399 views

bash: check50: command not found

This is how I checked using Ubuntu whether or not the check50 and submit50 commands were already installed. However, in my Visual Studio Code the commands are still not found. What should I do? It has ...
Hazel's user avatar
  • 1
1 vote
0 answers
145 views

Submit50 Could not connect to GitHub

Whenever I try to submit a problem, I get this error: Connecting.......... Could not connect to GitHub, it seems you are offline. Submission cancelled. What I did : First I create Virtual ...
snpay's user avatar
  • 11
1 vote
1 answer
79 views

CS50.h library in ubuntu

every time i create program i have to write "clang prog.c -o prog lcs50" link with cs50 but when I try "make prog" it prints following error: /usr/bin/ld: /tmp/cc8noHLN.o: in ...
Javohir Abdullayev's user avatar
0 votes
1 answer
110 views

cs50web socketio : broadcast does not include the sender

I work on ubuntu 18.04. I set up a virtual environment so that I am sure to work with python3 according to the instructions found here:https://vitux.com/install-python3-on-ubuntu-and-set-up-a-virtual-...
Karin's user avatar
  • 59
0 votes
1 answer
974 views

check50 and submit50 commands not found

I am opening cs50 after a few months and after trying update50, this is the message I'm getting at my command line: ~/workspace/pset1/ $ check50 cs50/2017/x/hello ...
Kewal Shah's user avatar
4 votes
4 answers
4k views

Ubuntu password required when starting apache 50 - pset7

Up until now the apache50 in de CS50 IDE was running perfectly. Suddenly when I want to start apache50 the message: [sudo] password for ubuntu: is shown in the terminal. What password should I enter ...
Arne Koning's user avatar
0 votes
1 answer
68 views

Setting up clang on ubuntu pc

I am using CS50 appliance to do psets but since I have a laptop with ubuntu on it, I would like to set up a similar environment to the cs50 in my laptop, starting with clang, and the C libraries that ...
JaviMar's user avatar
  • 125
0 votes
2 answers
52 views

Can't make @, [] etc in appliance

I cant make the @, [] etc in the appliance. I have a swedish keyboard on a MacBook Air from 2013. Any ideas? I have tried back and forth in the appliance's keyboard settings but can't really get it ...
lolleman's user avatar
1 vote
1 answer
86 views

Compiling pset3 breakout on my native ubuntu

I want to run the breakout game on my native ubuntu. I tried installing the SPL files and making certain changes to the Makefile. But it's still not compiling. Has anyone else got it to work?
Ankit Sharma's user avatar
0 votes
1 answer
366 views

ubuntu frozen at reboot

I've been using CS50 for 2 weeks with no problem until now. I hit restart in Ubuntu and now it's stuck at boot screen at "Restoring resolver state..." I've try'd waiting, hitting command Q or command ...
Touten's user avatar
  • 23
3 votes
1 answer
1k views

Error: Gedit not opening on VirtualBox Ubuntu 14.04

I recently downloaded VirtualBox and imported the CS50x Appliance. I am unable to open gedit and receive the below error message, included as a screen shot. If someone can assist me on what I should ...
jswein's user avatar
  • 33
0 votes
2 answers
210 views

Latest version of Check50

I've been having some issues with the appliance and want to emulate the environment on my Ubuntu 14.10 box. I have cs50.h working fine but would like to have check50 installed as well. I've followed ...
Robert H's user avatar
  • 116
1 vote
1 answer
117 views

No Dropbox icon

At the end of the set up of Dropbox within the appliance and creation of an account as indicated in Step 4 , -a there was no check box next to " Open my Dropbox folder " button and no Dropbox icon ...
lb_fin's user avatar
  • 11
3 votes
2 answers
553 views

Compile using make without the appliance in Kubuntu

I want to change the default options of make to be like the appliance one. I have installed clang and the cs50.h library but right now I compile the programs using clang hello_world.c -lcs50 -o ...
user avatar
0 votes
1 answer
3k views

Failed to open a session of vrtual machine, Non existent host networking interface name "VER_INTERNAL_ERROR"

I am getting this message when I try to start the CS50 appliance on Ubuntu 14.04: Failed to open a session of vrtual machine, Non existent host networking interface name "VER_INTERNAL_ERROR" I am ...
sinister's user avatar
  • 3,456
6 votes
6 answers
9k views

How to Install the Tools for the Course on Ubuntu

As per the question I have had nothing but trouble trying to use the virtual versions of the cs50 software, namely the virtual machine crashes runs slowly or just generally feels like my fingernails ...
user1568's user avatar