I am trying to run the window.c file I unzipped from src5m. It runs fine but when I copy and paste the code in a new gedit console and try to make it gives me this error message:

window2.c:1:10: fatal error: 'gwindow.h' file not found
#include "gwindow.h"

I have the SPL in the same subfolder and I'm running the ubuntu appliance 2014-29. I can't figure why it isn't linking with the SPL can somebody please help.

1 Answer 1


Do you have the following in your file?

#include <spl/gevents.h>
#include <spl/gobjects.h>
#include <spl/gwindow.h>

and are those files in the correct directory, /usr/include/spl ?

  • I added your lines of code still the same error
    – Marva
    Commented Aug 5, 2015 at 19:15
  • I'm trying to change name of window file in Makefile program but it still gives me the same error. Where is /usr/include/spl supposed to be located
    – Marva
    Commented Aug 5, 2015 at 19:16
  • /usr/include/spl is the full path name. In a terminal window, enter cd / to get to the main root directory and do an ls there and you will see usr among the folders.
    – Cliff B
    Commented Aug 5, 2015 at 19:23
  • Its not in there
    – Marva
    Commented Aug 5, 2015 at 19:30
  • run, cd /usr/include and check for spl. Also, have you run update50 lately? Finally, which version of the appliance are you on?
    – Cliff B
    Commented Aug 5, 2015 at 19:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .