1

Honestly, the frustrated smile (though still a happy one) doesn't leave my face while attempting this pset8 for a second week in a row. I had permission issues, and I have issues with addMarker and removeMarkers functions, which should have been the easiest part of the task.

I have decided to start it all over again; have deleted all my code and the whole pset8 I had on IDE, have downloaded a new one and have started working on it from scratch.

After downloading all files and setting correct permissions, I have opened my Mashup window; it works. Tried to head to https://ide50-username.cs50.io/phpmyadmin (username = my name) and got the following error:

phpMyAdmin - Error

The mysqli extension is missing. Please check your PHP configuration. See our documentation for more information.

The documentation leads to the following page http://docs.phpmyadmin.net/en/latest/faq.html#faqmysql

I am among less comfortable and I honestly, already having so much technical troubles with this pset, I am not confident in attempting to change IDE settings. Please, advice me on what I shall do. I can't finish this pset in such a long time. Thank you very very much!

2

We all know that phpMyAdmin can be flaky sometimes. Unfortunately, I can't tell you how to fix it -- but I can tell you how to use mysql50 shell from the command line. Try stuff like this:

mysql50 shell
SHOW DATABASES;
USE pset7;
SHOW TABLES;
DESCRIBE users;
SELECT * FROM users;
SELECT COUNT(*) FROM users;
quit

It's rock-solid and reliable, and it will help you get used to the way professional database administrators run things (not with mysql50 shell per se, but with mysql -h localhost -u user_name -p which is another way of getting to the same shell prompt).

Absolutely everything that can be done with phpMyAdmin can also be done from the mysql shell prompt. For example, you can paste the commands in a file like pset7.sql or pset8.sql directly into this prompt, and they will run just fine. Other things might be easier to figure out by pointing and clicking, but they are also possible with a little more research. Meanwhile, you can get a lot of stuff done this way while you wait to see if phpMyAdmin fixes itself.

| improve this answer | |
  • 1
    Thank you very much! Indeed shell commands are very helpful. I have used them on my machine when I was setting up mysql, and then when I tested it with a few tables. I have to learn yet how to use it in a more advanced way. Thank you for your help! Still hope to get help on fixing phpmyadmin - it's a handful tool for checking the data in a table. – Vitale Sep 2 '16 at 14:50
  • 1
    Thank you once again for your help! I have managed to create the places table, add US.txt content to it (with import file in bin directory) and check places table's content without running phpmyadmin ) Still I hope to get help on fixing phpmyadmin. – Vitale Sep 2 '16 at 16:26
  • @Vitale: I'm proud of you for persevering when you were frustrated. Know also that by entering your SQL statements directly at the shell prompt, you are practicing the skills that will make you "more comfortable" rather than "less comfortable". In my experience, people who always rely on phpMyAdmin usually end up remaining "less comfortable" for longer! – hotwebmatter Sep 5 '16 at 3:29
0

I was having the same problem. I just restarted the server, then restarted both apache50 and mysql50 in the terminal. Then tried again to open phpmyadmin webpage and it worked (make sure you load a non-cached page, force reload the page using SHIFT+F5 on chrome).

Enjoy :)

Merry Christmas!

José

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .