0

I am re-posting this question as really want to complete this pset and cant find a solution.

Have managed most of the problem set without a working map but now need to test markers.

After running flask the map shows briefly before i get “opps something went wrong”. I have checked the java console and am having the “RefererNotAllowedMapError”

I have tried update50 and re-downloading the source code (with provided api key) but result is the same. I'm not sure this is down to not being on the referrer list as from reading documentation i assume cs50 have used a wildcard to allow all ulrs ie. "http://ide50-*" or alike.

my ulr is http://ide50-USERNAME.c9users.io:8080/

Really would like to complete this problem set so if anyone has the same issue and/ or a fix please let me know.

Many Thanks

4
  • 1
    Speculation: my url is https://ide50-USERNAME.cs50.io:8080. I see two differences that could be problematic. https vs http and cs50.io vs c9users.io.Perhaps contact sysadmins@cs50.harvard.edu? – DinoCoderSaurus Jul 18 '18 at 12:12
  • Thanks Dino, that's a great starting point. Hadn't found an admin contact so also very useful. – PaleFire Jul 18 '18 at 12:20
  • Simply changing the ULR to your format has worked Dino. If you can add your comment as an answer i can mark it correct for anyone else with this issue. - Thanks again – PaleFire Jul 18 '18 at 12:27
  • Dude, I gave a hint, you made it an answer. Add more specifics about what you changed in your answer (for future readers), then in 2 days you can "accept it". – DinoCoderSaurus Jul 19 '18 at 2:16
1

Thanks to Dinos comment above i have now resolved this issue.

It turns out i was logged into the CS50 IDE under cloud9.

When running flask this produced a ulr: "http://ide50-USERNAME.c9users.io:8080/"

I first manually changed this to "https://ide50-USERNAME.cs50.io:8080/" and the map would run correctly, however. Flask would still give me the incorrect ulr and i would have to manually override this.

The next time I logged into the IDE I noticed the ulr started with "ide.c9.io". I now log into the IDE using "https://ide.cs50.io/username/ide50" and flask produces a link that connects to google maps correctly.

Hope this helps anyone else with this issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .