~/workspace/ $ submit50 cs50/2018/x/marioless
Invalid slug. Did you mean to submit something else?
~/workspace/ $ submit50 cs50/2018/x/marioless
Invalid slug. Did you mean to submit something else?
~/workspace/ $ 

2 Answers 2


You need to follow the instructions exactly. The spec says:

Write, in a file called mario.c in ~/workspace/pset1/mario/less/, a program that recreates this half-pyramid using hashes (#) for blocks.

So this means that you need to create some folders, which is explained in the very first Hello problem. (use mkdir to create a folder and cd to change into that folder).

Then, be sure to save your code as mario.c in that folder.

Once you've done all that, then run check50 as shown in a terminal in that folder:

check50 cs50/2018/x/mario/less
  • but when i use mkdir for making a dir/ectory it shows me that the file does not exist? what should i do then Commented Jun 3, 2018 at 7:59
  • not sure what you mean. did you create the pset1 directory for the Hello problem? So once you cd into that, you should be able to create a mario directory, then cd into that, and create a less directory. You then save your mario.c inside that less directory.
    – curiouskiwi
    Commented Jun 3, 2018 at 8:09
  • i dont no what to do?yes i created pset1. can you just tell me step by step process that i should crete in the terminal . please do help Commented Jun 3, 2018 at 8:34
  • if you are in ~/workspace then you need to cd pset1 to move to the pset1 directory. Then you need to use mkdir mario to create the mario folder, then cd mario to go into that, and then mkdir less to create the less folder. If this is too confusing, I suggest you go back to the Hello program and be sure you understand how to navigate the folders.
    – curiouskiwi
    Commented Jun 3, 2018 at 8:41
  • so i should create two directory one for mario and one for less Commented Jun 3, 2018 at 8:43

An invalid slug error means that the parameter following check50 or submit50 is incorrect. Go back to the problem spec and see what it's supposed to look like. I'll guess a missing slash or something.

If this answers your question, please click on the check mark to accept. Let's keep up on forum maintenance. ;-)

  • I guess I did whatever it was instructed in the pset1. I still get the same error. What do i do know? Commented Jun 2, 2018 at 5:28
  • Did you have a slash between mario and less?
    – Cliff B
    Commented Jun 2, 2018 at 5:30
  • no, i created a file as marioless.Is that wrong. Commented Jun 2, 2018 at 7:43
  • The code file should be named mario.c but that's a separate problem. The submit50 (and check50) command is invoked like this: submit50 cs50/2018/x/mario/less
    – Cliff B
    Commented Jun 2, 2018 at 7:47
  • so should i change it? Commented Jun 2, 2018 at 7:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .