0

I started cs50edx in 2014 & took a long break over year-end. When I returned, edx guided me towards the new cs50x 2015. There were pset changes from 2014 to 2015, and I can't figure out how to update the code in ~cs50. For example, in "Mispellings" (pset6 in 2014; pset5 in 2015), the code for "dictionaries" & "texts" is in my ~cs50/pset6 folder. But Speller (which the instructions say not to modify) expects it to be in ~cs50/pset5.

How can I align the contents of these ~cs50 folders with this year's psets? FWIW, I'm using the same computer as in late-2014, just with a new license for Appliance.

I'm well out of my depth on this and would appreciate any help.

0

You will need to download the new appliance that is being used this year. I assume you are using appliance version 19 (the one that was used for the 2014 edX course). Here is the new appliance: https://manual.cs50.net/appliance/2014/#how_to_install_appliance

You should be able to use the same hypervisor that you have been, but just follow the link for Mac or Windows and you'll find the link to the version 2014_29 appliance.

| improve this answer | |
  • Yes!!! Your advice enabled me to take care of the problem for both Mac and Windows. (I have Bootcamp on my Mac & keep an Appliance on each "side."). Thanks very much. – Robert Feduniak May 8 '15 at 20:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .