1

When I go to the webpage in a Chrome browser outside the appliance, there is a Google map of the Harvard area on the right, and a "Download the Google Earth Plugin" window on the left. I have downloaded the plugin 8 times, restarted my computer several times, but cannot get the opening page to use the plugin. In the console there is the message:

Uncaught ReferenceError: ERR_CREATE_PLUGIN is not defined

I went into the service.js file that is generating this message, but have not been able to figure out how to get the browser to load the Google earth plugin page. Again, I am accessing the page from outside the appliance, on an up-to-date MacOS, and up-to-date Chrome browser. Any ideas?

IN ADDITION: I just tried accessing the page in a Safari browser, and it worked fine. I would still like to know why it is not working in Chrome (I would think that a Google plugin should work in Chrome), but I assume it is okay to complete the assignment working on it in Safari.

Thanks, Jordan Ball

1
  • Also having trouble in Chrome while Safari is using the plug-in just fine. – Daniel Levi Dec 1 '14 at 6:57
0

Same thing here - works in Safari, not in Google Chrome. Google Chrome seems to have spent much of 2014 removing support for NPAPI (a primary component of Google Earth).
http://blog.chromium.org/2013/09/saying-goodbye-to-our-old-friend-npapi.html https://developers.google.com/earth/documentation/ (read fine print)

The issue appears to be especially pronounced on Mac OS, for various reasons.

Firefox is going down a similar road with deprecating NPAPI, but still allows users to launch plugins (Google Earth) manually within the browser. Firefox also has similar development features to Google Chrome, so many of the developer troubleshooting features will still be available to you.

2
  • 1
    So. Is there a solution? – Daniel Levi Dec 8 '14 at 3:45
  • Use Firefox. I couldn't find a solution for Google Chrome. With that being said I think I may skip this problem set. I make 1 step forward and three steps back each time I debug something seemingly outside the realm of the problem set. – Wes Roach Dec 18 '14 at 7:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .