0

i just installed Vmware player and cs50 appliance. It all works good but i'm unable to find cs50 directory. And in terminal also it shows only four directories and when i write "cd CS50"it says "no such directory found". And with this i'm unable to complete my courses. Please help

2
  • There is no such cs50 directory or folder anywhere in my appliance. I've checked in home directory or searched in home. And also tried in terminal window by changing directories but it is not there. Can anyone tell me how can i get it by downloading it from somewhere or anything else. Please help. – Sambhav Kaul Jun 29 '15 at 17:09
  • Please edit to include the output of the command ls-la. This should help us. – Tim Aug 9 '18 at 1:11
0

The CS50 folder is in the home directory. So if you want to use cd, please use

cd /home/cs50

Instead of

cd cs50

1
  • This is not working. There is no CS50 folder in home directory and in the whole appliance. I've searched everywhere. The command "cd/home/cs50" is also not working at all. – Sambhav Kaul Jun 29 '15 at 13:48
0

directory and file names are case-sensitive in the appliance. that is, a directory with the name cs50 (lowercase) is not the same as a directory with the name CS50 (uppercase).

in order to navigate to the cs50 directory on the appliance, you should execute

cd ~cs50
2
  • I know that that uppercase and lowercase matters in appliance. I've executed "cd ~cs50" it also doesn't work. I mean seriously there is no such folder name cs50 in my appliance. Can I download it somewhere or what else i can do to have it. Please tell me – Sambhav Kaul Jun 29 '15 at 17:06
  • @SambhavKaul which version of the appliance are you using? did you execute update50? – Kareem Jun 29 '15 at 17:19
0

There needs to be a space between 'cd' and '/home/cs50' as Ahmed has written. You can also navigate manually by opening a new terminal window and typing cd .. and hitting enter, entering ls after you have done this should show the jharvard and cs50 directories. You can also access cs50 through the graphical interface by double clicking your Home folder on the desktop, going to the search bar that shows your file path, deleting /jharvard/ and hitting enter.

1
  • I've also tried with space but it also doesn't work. And I've also tried graphical interface but there is no cs50 folder anywhere. – Sambhav Kaul Jun 29 '15 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .