1

I can't correctly copy and paste from my appliance to my host, and vice versa. When I copy something from the appliance, I can paste it elsewhere in the appliance, but not outside the appliance. It was all working fine a few days ago- I could copy something from outside and paste it inside the appliance, and vice versa. When I copy something from outside of the appliance, I can not paste it inside the appliance. The only possible cause that I can think of is the new virtual machine I created: I created a second virtual machine using the CS50 2014-29 template.

EDIT 7/19/15: I'm not sure what caused it, but now I can copy and paste. I have done update50, restarted the appliance and my computer, and some other things that might have helped.

5
  • Please add information to your question that might help someone reproduce the problem: Which host OS and OS version? Which virtualization app (VMware Workstation, Player, Fusion, VirtualBox) and what version? What has changed since copy+paste last worked? (Virtualization app update? update50?) Does copy+paste work in the 2nd VM? Did copy+paste failure in 1st VM coincide with installation of 2nd? – glennholloway Jul 16 '15 at 4:28
  • Host OS: Windows 7. I have VMware Workstation 11 and VMware Player. I have not updated the appliance since copy and paste last worked, or downloaded any software on my host computer or in the appliance. Copy and paste does work in the 2nd VM. And yes, the copy and paste failure did coincide with the creation of the second. Thanks for your help! – i_am_david Jul 16 '15 at 14:37
  • By the way, I have used system restore and restored my computer back to when copy and paste was working (before the 2nd appliance was created), but it still doesn't work. Windows removed the 2nd appliance, but the first appliance still doesn't copy and paste correctly. – i_am_david Jul 16 '15 at 14:51
  • Are there any other "host/guest integration" problems? E.g., does the mouse pointer travel seamlessly between host and guest? Does drag-and-drop work between the desktops? When you resize the appliance window, does the appliance screen adjust correctly? E.g., does full screen mode work correctly? In a terminal in the appliance, please run the vmware-user command, with no arguments. Does that make a difference? – glennholloway Jul 16 '15 at 19:53
  • Full screen mode does work. The mouse travels fine. The appliance screen does adjust correctly. I cannot drag and drop from host to appliance. I tried vmware-user and vmware -user, but neither can be found my the terminal. – i_am_david Jul 16 '15 at 22:51
1

At the top taskbar, under "Devices" go to "Shared Clipboard" and adjust the settings. You can use the clipboard function to copy to or from the guest (in CS50, the appliance) to your computer. Options are from guest to host, from host to guest, or bidirectional.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .