How do I copy and paste to and from the appliance ie: from my computer(host) to the appliance(guest) and visa versa? I looked at Appliance - Host Copy and paste problems, but I could not find "Shared Clipboard"(maybe I didn't get the right "Devices" either). I am running appliance 2014 in the 2014 course and did update50. It works in appliance 19(2013 version) though. Here is what my appliance looks like: appliance Thanks!


2 Answers 2


As you mentioned on this post: How do I enlarge my appliance?

This answer: https://cs50.stackexchange.com/a/14519/7276

solves this problem too. Cheers!


For Hypervisor: This feature should be enabled by default. Maybe you turned it of accidentally. Choose Edit > Preferences. On the Input tab, set the check box beside Enable copy and paste to and from virtual machine.

    Link to vmware docs

For VirtualBox: You must explicitly enable it by going to |General|Advanced and setting Shared Clipboard to "Bidirectional".

    Link to VirtualBox forum

  • Where is edit? I can't seem to find it. My appliance window says: "appliance50-2014-vmware-VMare Player (Non-commercial use only)". The Toolbar says "Player", "Suspend Guest", "Send Ctrl, Alt, Del to virtual machine", "Enter full screen mode", "Enter Unity mode", "Hide devices", "Hard Disk (SCSI: 16 GB)", "Network Adapter: NAT", "Network Adapter 2: Bridged(Automatic)", "Network Adapter 3: Bridged(Automatic)", "Sound Card: Auto detect", "Chicony HP Webcam-50", "Atheros Bluetooth USB Host Controller". Am I even looking in the right place? I'll put a screenshot in my original post.
    – Matthew.A
    Commented Oct 12, 2015 at 2:22
  • I don't use VMware, but I think that has to be somewhere a control panel, a general panel where to start the appliance. If you search in your installed programs (on your own pc) for "VMware workstation" and open it, you should see something like this. There you find the "edit" menu. Commented Oct 12, 2015 at 21:13
  • I don't see anything like that anywhere. The most option-loaded place I could find is in my picture.
    – Matthew.A
    Commented Oct 21, 2015 at 3:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .