0

I am getting this message when I try to start the CS50 appliance on Ubuntu 14.04:

Failed to open a session of vrtual machine, Non existent host networking interface name "VER_INTERNAL_ERROR"

I am using Virtualbox Graphical User Interface 4.3.10_Ubuntu r93012

VER_INTERNAL_ERROR

I have visited this question, but my problem seems to be somewhat different.

2

The first and the foremost solution to the problem was google, which lead me to this link where David Sir posted about this error. Although that was on Mac OS X. enter image description here

The link redirects to this, 3rd topic from the top. I have made a copy of those instructions here.

For some reason, VirtualBox doesn’t always come with a "host-only adapter" configured. (A "host-only adapter" lets you connect to the CS50 Appliance via HTTP, SSH, and the like.) To resolve this problem:

1. Launch VirtualBox. (If VirtualBox is already running, shut down any virtual machines that are running, as by clicking the red circle in the top-left corner of each’s window.)

2. Select Preferences… under VirtualBox’s File menu.

3. Click Network.

4. If VirtualBox Host-Only Ethernet Adapter does not already appear in the white box under Host-only Networks, click the Virtualbox-plus.png icon to the right of that box, and VirtualBox Host-Only Ethernet Adapter should then appear in the box.

5. Click OK.

6. Single-click whichever virtual machine originally triggered the error (e.g., the CS50 Appliance), then click Settings.

7. Click Network.

8. Click each of Adapter 1, Adapter 2, Adapter 3, and Adapter 4. If any of them has both Enable Network Adapter checked and a value of Host-only Adapter for Attached to (as should the CS50 Appliance for Adapter 2), ensure that the adapter also has a value of VirtualBox Host-Only Ethernet Adapter now for Name, selecting it yourself from the drop-down menu next to Name yourself if necessary.

9. Click OK.

10. Start whichever virtual machine originally triggered the problem (e.g., the CS50 Appliance); it should now be gone.

And you are done!


Everything should have worked fine after this, but not for me. I received the message a critical error has occured while running the virtualmachine and the machine execution has stopped.

I removed it by :

  1. Right Click on vm

  2. Settings -> System -> Processor

  3. Check Extended Features : Enable PAE/NX .

2
  • You should be able to accept your answer now, assuming you intend to.
    – Air
    Sep 4 '14 at 22:51
  • ya, I forgot that, thanks for remnding
    – sinister
    Sep 5 '14 at 0:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .